500 EsocketException: ... cannot convert port 'ftp', 10004

This forum is designated to discuss WISE-FTP.
Post Reply
basementjack
Newbie
Newbie
Posts: 1
Joined: September 7th, 2005, 9:03 pm

500 EsocketException: ... cannot convert port 'ftp', 10004

Post by basementjack » September 7th, 2005, 9:10 pm

Hi,

I have the Wise-FTP from 1and1 internet. It hasworked flawlessly for months and months.

Today I tried to connect to my 1and1 site and I am getting the 'unable to connect to ....! (500 EScocketException: connect: WSocketResolvePort: Cannot convert port 'ftp', Error #11004)

I tried another site (non-1and1) and I cannot connect to that either.

Then I tried to ftp to my 1and1 site from internet explorer 6 and that worked fine. So I suspect somethings in the way of Wise FTP, but I do not know what.

Have any recent windows updates broken the version I have ?

(My screen says 3.0.0.18
hmm, it shows unregistered trial version 30 days left too (I just did an auto update)

Anyhow I've tried the obvious like turning off windows firewall and zone alarm and still no luck with wiseftp...

- Jack

User avatar
Support (AceBIT)
AceBIT
AceBIT
Posts: 2463
Joined: March 27th, 2003, 10:53 am
Contact:

Post by Support (AceBIT) » September 8th, 2005, 9:37 am

Hello,

you said that you still use the old version of the program, so it seems that something went wrong during the live update. As most probably the problems are caused by the old version, you first should install the update to version 3.1. What happens when running the integrated live-update? Does this show any error message? Or is it telling you that there's no update available even if you still have version 3.0.0.18 (see menu help -> about)?
AceBIT - Support -

waza
Newbie
Newbie
Posts: 1
Joined: September 9th, 2005, 4:34 pm

Still cannot connect with same problem after upgrade

Post by waza » September 9th, 2005, 4:41 pm

I had the same problem and upgraded twice to 3.1 and still getting the error.

! Unable to connect to brholistic.co.uk! (500 ESocketException: connect: WSocketResolvePort: Cannot convert port 'ftp', Error #11004)

Windows firewall has Wise-FTP listed as exception so thats not the problem.
Did you resolve yours or dows anyone else have any ideas?
Tx

AceBIT Support

Post by AceBIT Support » September 13th, 2005, 6:35 pm

Hello,

are you using any kind of Security Software? Firewall? Anti-Virus? Are you using a proxy server or a router to connect your pc to the internet?

__________________
Best regards
AceBIT - Support -

alanm
Newbie
Newbie
Posts: 1
Joined: October 23rd, 2005, 12:54 pm

Post subject: 500 EsocketException: ... cannot convert port

Post by alanm » October 23rd, 2005, 12:59 pm

I'm also having the same problem with Wise-FTP from 1and1 internet.

As basementjack I'm also with 1and1 internet, and never had any problems connecting to our ftp service with Wise-FTP until the beginning of September.

I can still access the 1and1 ftp service through other routes (like via command-line ftp or Dreamweaver), but continually get the 500 / #1104 error with Wise-FTP.

I've upgraded to the latest version with no joy.

Running Win XP HE SP2 & Norton Internet Security 2005.

Any news / advice???

Alan

Serghei (AceBIT)

Post by Serghei (AceBIT) » October 24th, 2005, 10:23 am

Hello,

Usually this error (#11004) is caused by missing or corrupted files
'services' and 'protocol' on your system C:\<WINDOWS>\system32\drivers\etc\

In most cases, a third-party program has renamed these 2 files:
'services' -> 'services.dat'
'protocol' -> 'protocol.dat'
and as a result many other programs like Wise-FTP cannot convert string 'ftp' into a default port number.

To fix this problem we can suggest 2 solutions:

1) Always use in Wise-FTP Site Manger real number as 'Port' (usually this is 21 or 3128);

2) Rename the above files in C:\<WINDOWS>\system32\drivers\etc\ back:
'services.dat' -> 'services'
'protocol.dat' -> 'protocolt'

These files must have NO any extensions!

Best regards

robingf
Newbie
Newbie
Posts: 1
Joined: October 29th, 2005, 8:43 pm

Post by robingf » October 29th, 2005, 8:47 pm

I had the same problem .... 1and1 not much help. In my opinion it is they who have changed something.

Ayway in the end I changed the PORT setting from ftp to 21 in each account I use to connect as well as in the default preferences.

All now working again!

Steve :roll:

Post Reply