Page 1 of 1

Mystifying SFTP failure

Posted: July 28th, 2012, 9:51 pm
by Philip Goddard
I have been using Wise-FTP for yonks, and have the current version, 7.04, running in Win7 x64.

Just today, all attempts of mine to access my webspace via my usual SFTP connection have failed. This appears not to be a problem with my hosting company (1&1), because (1) I can access all my sites just fine via the FTP protocol (and thus of course with insecure connections) - and (2) I tried installing FileZilla to see what happens when I try to use it to do SFTP accesses to my websites, and it managed fine. However, there is the difference, that FileZilla doesn't yet support password-protection of one's private key, so I had it using the same private key as Wise-FTP, but unlocked.

Now, one really odd thing about these Wise-FTP failures is that, each time, absolutely no entries appear in its FTP log, and, although a session window for the remote connection has opened, it doesn't time out and either close or give any message. That's a new one for me; with ALL previous connection or transfer failures over the years there have been entries in the FTP log, which at least let one know at what point in the process the failure occurred, and, if lucky, the actual reason for failure. But today absolutely nothing was showing there for any of my attempts - and also when I clicked on the close-box for the attempted connection, I got immediate closure of that session, with no prompt asking if I really want to cancel it.

I tried re-making the SSH key pair, but that didn't change anything. Also, I am not aware of any change on my system between my uses of the program yesterday (all successful) and my consistent failures with it in SSH mode as from early this morning.

Any ideas, please? At the moment I'm having to use FileZilla, and that's the way it will have to stay until I can get this sorted out with Wise-FTP. -- Many thanks.

Re: Mystifying SFTP failure - Solved!

Posted: July 28th, 2012, 10:37 pm
by Philip Goddard
Well, blow me down - no sooner than I'd submitted my post above, I did a little further experimentation and got Wise-FTP working properly again for SFTP!

What I did was, in Site Manager, to go into the Advanced dialog for SFTP, and try each of the three Method options there. 'Password' worked, but the other two options didn't. Then, having chosen the 'Password' option, the details of private key and its password had been wiped out, so I rather glumly re-entered them (fortunately having stored a record of the password elsewhere) - but then found that SFTP worked fine with the option for private key plus password. I then established that what needed re-entering was specifically the private key password - for each of my sites. Because Wise-FTP doesn't give any opportunity to view the private key password, I had no means to see what the corruption was, but it was weird, that apparently the private key password for EACH of my sites had got corrupted at the same time (but was still the correct length), without my having done anything obvious that might have affected it - and clearly there is a bug or design flaw in Wise-FTP in that it didn't report the password problem and just left me scratching my head, staring at a blank FTP Log!

At least, I'll know what to do next time this happens - and maybe my posts here will help the odd other people who have hit upon the same problem! :clap:

Re: Mystifying SFTP failure

Posted: August 9th, 2012, 5:40 pm
by AceBIT
Thanks a lot for sharing your solution!