I can't generate SSH key pairs in WFTP 9

This forum is designated to discuss WISE-FTP.
Post Reply
Philip Goddard
Member
Member
Posts: 7
Joined: December 23rd, 2008, 10:24 am
Location: Exeter, UK
Contact:

I can't generate SSH key pairs in WFTP 9

Post by Philip Goddard » October 11th, 2015, 11:18 pm

I've just been tearing my hair because I was trying to submit a support ticket, and the form refused to submit, claiming that there was an empty required field, which emphatically there was not.

So, I'm having to put this support request here, because it MUST be fixed asap.

OS: Windows 10 Pro x64

In WFTP 7 I had the SSH key pair generation work perfectly straightforwardly, and also SSH2 connections worked fine for WFT9 at first after I upgraded earlier today. However, I then found that the v.9 installation had referenced the key files in the v.7 installation instead of doing the intelligent thing of actually transferring them, so I myself transferred the files over to the v.9 installation and changed the key file paths in the latter to refer to the files actually in that program folder, as I wanted to clear the older version from my computer (I do wish WFTP upgrade installations would at least optionally replace the older version rather than effectively treating it as a fixture!). The only trouble is that I cannot log in at all now with SSH. When I attempt a connection, nothing at all shows in the FTP log.

I tried generating a new pair of keys, but the key pair generation dialog, while allowing me to enter the key filenames and a password, doesn't respond to my clicking 'Generate'. So I'm left high and dry without SSH.

Standard insecure FTP connections work fine.

So, I'd most appreciate your assistance over this, so I can get secure connections again. -- Many thanks.

Kind regards,
Philip Goddard.

Philip Goddard
Member
Member
Posts: 7
Joined: December 23rd, 2008, 10:24 am
Location: Exeter, UK
Contact:

Re: I can't generate SSH key pairs in WFTP 9

Post by Philip Goddard » October 16th, 2015, 10:14 am

Oh really - STILL no response from Acebit Support! - In the meantime I did finally manage to get WFTP9 to do SFTP, and to generate a key pair - BUT its operation with SFTP is buggy and not fit for purpose. It shows the Logs folder on my 1&1 webspace as being empty, whereas with straight FTP, and SFTP on other FTP clients I get a full listing. And it behaves really clunkily when I have it open on the Websites folder on my remote webspace for synchronized browsing through the subfolders. I didn't have any of these issues with WFTP7. My only reason for upgrading, really, was that WFTP7 was consistently failing to run in Win10, even after reinstallation.

Because of Acebit's lack of response to my original post here, and alternative FTP clients lacking features that would make them fully workable for me, this morning I tried installing WFTP7 again (having fully removed the previous installation and its remnants), but this time installing the final public build of that version, which I didn't have before. Thank goodness, that actually works, and its SFTP works just fine. So, after all that I don't need this rubbish v.9 at all - though would have liked its HTML files optimization feature.

Please, Acebit, I want either a refund or a properly functioning WFT9. -- Thank you.

Post Reply