Firefox extension incomapatible (HELP!)

This forum is designated to discuss Password Depot.
Post Reply
69800
Member
Member
Posts: 13
Joined: November 26th, 2012, 11:02 pm

Firefox extension incomapatible (HELP!)

Post by 69800 » April 13th, 2013, 2:13 pm

I upgraded firefox to 20.01 and now password depot does not work in firefox because it is incompatible. I cannot find where to update this extension.

I have checked for updates in password manager 6.24 but is says I am up to date. I see there is a new password depot 7.0 but It says I have to pay to upgrade and my old 6.24 works fine

Birke (AceBIT-Team)
Guru
Guru
Posts: 254
Joined: November 19th, 2012, 5:58 pm

Re: Firefox extension incomapatible (HELP!)

Post by Birke (AceBIT-Team) » April 15th, 2013, 5:32 pm

Hi 69800,

Firefox 20 is supported by Password Depot since version 7.0.1. Thus if you would like to use Firefox 20 together with Password Depot, please purchase an upgrade from Password Depot 6 to 7. Alternatively, we recommend using a browser other than Firefox, e.g. Chrome or Internet Explorer, since these browsers do not permanently release upgrades necessitating browser add-on changes as Firefox does.

69800
Member
Member
Posts: 13
Joined: November 26th, 2012, 11:02 pm

Re: Firefox extension incomapatible (HELP!)

Post by 69800 » April 19th, 2013, 5:46 pm

I wish I would have known I had to buy and upgrade every time Firefox updated. Were are the instructions on how to upgrade?

User avatar
AceBIT
Site Admin
Posts: 3450
Joined: March 20th, 2003, 8:08 pm

Re: Firefox extension incomapatible (HELP!)

Post by AceBIT » April 19th, 2013, 6:53 pm

69800 wrote:I wish I would have known I had to buy and upgrade every time Firefox updated. Were are the instructions on how to upgrade?
Dear 69800,

Version 6 was released in June, 2011, so almost 2 years ago. For almost 2 years we updated this version for free and now we released version 7.
Beste Grüße aus Darmstadt! - Best regards from Darmstadt!

AceBIT GmbH, Holzhofallee 15, 64295 Darmstadt, Deutschland - Tel.: +49 61 51 136 50-0, Fax: +49 61 51 136 50-20, E-Mail: info@acebit.de, Web: https://www.acebit.de

69800
Member
Member
Posts: 13
Joined: November 26th, 2012, 11:02 pm

Re: Firefox extension incomapatible (HELP!)

Post by 69800 » April 25th, 2013, 3:39 am

Ok
My error for buying in 3 months ago. I still need to know what the procedure is for upgrading.

Birke (AceBIT-Team)
Guru
Guru
Posts: 254
Joined: November 19th, 2012, 5:58 pm

Re: Firefox extension incomapatible (HELP!)

Post by Birke (AceBIT-Team) » April 30th, 2013, 2:38 pm

Dear 69800,

If you would like to switch from an older version of Password Depot to version 7, please purchase the corresponding upgrade on following web page:

http://www.password-depot.com/order.htm

Having purchased the upgrade, you can download version 7 here:

http://www.password-depot.com/download.htm

Post Reply