Need help with mail settings

This forum is designated to discuss WinSurvey.
Post Reply
Jason
Member
Member
Posts: 16
Joined: June 15th, 2004, 3:59 pm

Need help with mail settings

Post by Jason » July 9th, 2004, 11:37 am

Hi

I can't get the asp mail to work. I ave published a survey to our asp server, and there are three files: Survey.html, Questionnaire.asp and Processform.asp. I have spoken with the server admin to make sure that it supports asp mail, and it does.

However, when I press the submit button I get a "Page Cannot be found Error" and I do not receive my expected email!

I think the documentation is a bit vague on how you set this up! I have a couple of questions about the settings dialogue.

1)In this first tab,.what do I put in "Admin email Address"? I assumed this was the address where the survey responses should be sent?

2) In the forth tab, "Email Settings", what is this for? What is this Daemon mail?`

Do I not need to enter our server's smtp settings anywhere? Is there anything I'm missing?

Please help!

Serghei (AceBIT)

Post by Serghei (AceBIT) » July 9th, 2004, 2:09 pm

Hello,

The error "Page Cannot be found Error" is rather caused by a missing file in your survey directory then a problem with email. Please check the following:
1) Open the survey properties dialog box and make sure the "CGI script path" is "processform.asp"
2) Save the survey and click "Publish survey on the web", select "Save files locally, and save the files in a directory on your disk.
3) Make sure ALL the generated files are published at the same directory on your server (including "standardthanx.html", etc)

About other questions:
"Admin email Address" - this is an email address for recieving responses via your default email client. When a visitor submits the survey form, the "processform.asp" generates a a message with results and sends this message to the specified email address.

"Email Settings" tab specify email settings if you wish to send a visitor a confirmation email. "Survey daemon email" is "Reply-To" address for the generated emails. Note, you may use these settings only if your survey contains a field for respondent email address! You will need to specify the corresponding field in the "Emal settings" -> "Email answer".

Best regards

Jason
Member
Member
Posts: 16
Joined: June 15th, 2004, 3:59 pm

Post by Jason » August 16th, 2004, 2:36 pm

thanks. I'll go through it all again and see if I can get it to work.

Jason
Member
Member
Posts: 16
Joined: June 15th, 2004, 3:59 pm

Server Information at last!!!

Post by Jason » October 6th, 2004, 9:42 am

Finally, I have the information!!

1) The mail component they are using is called CDonts.
2) Don't need to specify the ip - they say we should use the name.
3) No authorisation is required. It only accepts mail from its own Ip address.

Now what?

Serghei (AceBIT)

Post by Serghei (AceBIT) » October 6th, 2004, 1:16 pm

Hello!

Then please try the following:

1) Open your local file "questionnaire.asp" in any text or HTML editor;

2) Locate the string:
mailComp="ASPMail"
and replace it with this string:
mailComp="CDONTS"

3) Make sure the string
email_from_email="..."
contains an email address with the same domain as your server has. I.e. if you survey is published on http://www.myserver.com, then write there something like:
email_from_email="winsurvey@myserver.com"

4) Save the file "questionnaire.asp" and upload to the same directory where all your survey files are published.

Best regards

P.S. The "CDONTS" mail component was used on Windows NT. Newer versions of Windows (2k, XP, 2003) do not support it anymore. So if you continue experience troubles with mail settings please contact us at support@acebit.com - we will try to find a solution.

Jason
Member
Member
Posts: 16
Joined: June 15th, 2004, 3:59 pm

Post by Jason » October 11th, 2004, 9:23 pm

Many thanks for the help, but time ran out on this one, I'm afraid. We did the survey manually.

I'll continue working on this response handling problem until a new survey opportinity arises, and then perhaps everything will be ready, and hopefully we can use it.

Jason

Post Reply