PWD Overlay verhindert login / Sicherheitsabfrage bzgl. URL

Forum für den Passwort-Manager "Password Depot".
Post Reply
godmd
Guru
Guru
Posts: 286
Joined: February 7th, 2005, 3:30 pm

PWD Overlay verhindert login / Sicherheitsabfrage bzgl. URL

Post by godmd » October 28th, 2012, 12:32 pm

Hallo,

seit einiger Zeit hatte ich bei einer meiner Banken Probleme mit dem Login. Benutzername und PW wurden von PWD wie gewohnt automatisch eingetragen, aber der Anmeldebutton auf der Seite reagiert in Firefox (aktuelle Version), in IE8 erst nach mehrmaligen Versuchen. Wie ich festgestellt habe, liegt das wohl am PWD Overlay. Wird das automatische Ausfüllen deaktiviert, funktioniert das Login. Ich habe keinen konkreten Vorschlag zur Abhilfe, aber vielleicht fällt Ihren Programmierern dazu ja etwas ein.

Eine weitere Beobachtung, die ich gemacht habe: Manchmal passiert es mir, dass ich F6 drücke - auf einer falschen Seite, d.h. wenn in der PWD-Topleiste z.B. versehentlich noch die Zugangsdaten meiner Bank aktiv sind, obwohl ich mich in ein Forum einloggen will. In diesem Fall werden die Loginfelder des Forums mit meinen Bank-Logindaten gefüllt. Eine recht unsichere Sache, denn die Daten werden ja nicht nur im Browser gespeichert (je nach Einstellungen), sondern i.d.R. auch in den Logdaten der jeweiligen Website. Hilfreich könnte es hier sein, wenn PWD vor dem Eintragen der Kennwörter die URL abfragen würde, ob die zum Kennwort gespeicherte URL mit der im Browser aufgerufenen übereinstimmt und einen Warnhinweis ausgibt, wenn dies nicht der Fall ist.

Freundliche Grüße
godmd

User avatar
AceBIT
Site Admin
Posts: 3450
Joined: March 20th, 2003, 8:08 pm

Re: PWD Overlay verhindert login / Sicherheitsabfrage bzgl.

Post by AceBIT » November 2nd, 2012, 12:33 pm

Hallo godmd,

wenn der Anmeldebutton deaktiviert bleibt, ist dann das ganze Browser-Fenster "eingefroren"? Erscheint dann nach einiger Zeit ein Skriptfehler, der fragt ob das Skript weiter ausgeführt werden soll?
Beste Grüße aus Darmstadt! - Best regards from Darmstadt!

AceBIT GmbH, Holzhofallee 15, 64295 Darmstadt, Deutschland - Tel.: +49 61 51 136 50-0, Fax: +49 61 51 136 50-20, E-Mail: info@acebit.de, Web: https://www.acebit.de

godmd
Guru
Guru
Posts: 286
Joined: February 7th, 2005, 3:30 pm

Re: PWD Overlay verhindert login / Sicherheitsabfrage bzgl.

Post by godmd » November 2nd, 2012, 3:25 pm

Hallo Site Admin,

man kann weder von deaktiviert im Sinne von abgeblendet oder ausgegraut sprechen, noch von einem eingefrorenem Fenster. Es zuckt ganz kurz beim Anklicken des Anmeldebuttons, als würde es weitergehen.

Meldungen beschränken sich CSS-Warnungen seitens der Bank (box-shadow und border-radius - das Übliche). Zusätzlich wird folgender Warnhinweis im Webdeveloper angezeigt:

Zeitstempel: 02.11.2012 14:14:12
Warnung: Ein Formular wurde in der windows-1252-Kodierung abgesendet, das nicht alle Unicode-Zeichen kodieren kann, daher könnten Benutzereingaben beschädigt sein. Um dieses Problem zu vermeiden, sollte die Seite geändert werden, sodass das Formular in der UTF-8-Kodierung gesendet wird, entweder durch Änderung der Kodierung der Seite selbst oder durch Angabe von accept-charset=utf-8 am form-Element.
Quelldatei: https://bankingportal.naspa.de/portal/portal/Starten
Zeile: 0

Die Frage, ob ein Skript trotz eines Fehlers weiter ausgeführt werden soll, kenne ich nur von Thunderbird, d.h. ein solches Dialogfenster erscheint hier nicht.

Wenn ich in PWD das Addon deaktiviere und nur den Button fürs (halb-)automatische Ausfüllen verwende, dann wird das Formular verarbeitet (bei gleichbleibender Warnmeldung wegen der Kodierung).

Hilft das weiter?

Viele Grüße,
Anke

HeyJoe
Expert
Expert
Posts: 30
Joined: November 20th, 2012, 4:19 pm

Re: PWD Overlay verhindert login / Sicherheitsabfrage bzgl.

Post by HeyJoe » November 20th, 2012, 4:48 pm

Hallo godmd,
Deinen Beitrag vom 28.10.12 - erster Absatz - kann ich voll bestätigen. Auch ich habe dieses Problem bei der Anmeldung bei meiner online-Bank seit der Version 6.2.0. Hatte das dem support gleich geschrieben und gehofft, daß das mit der nächsten Version vorbei ist. Aber die neue Version 6.2.1 hat diesen Fehler leider nicht behoben und die Rückfrage bei support brachte die Antwort, daß man den Fehler leider nicht nachvollziehen könne.

Also ich gebe in Password Depot wie bisher den Befehl ein für Benutzername und Kennwort automatisch füllen (Url im Browser öffnen), dann wird auch alles automatisch gefüllt, klicke ich dann aber auf "Anmelden" löschen sich die Felder "Anmeldename" (=Benutzername) und "PIN" (=Kenwort) einfach wieder. Ich ziehe sie dann mit "drag & drop" in die entspr. Felder, dann geht es.

Wohlgemerkt, das passiert nur bei meiner Hausbank seit der Version 6.2.0, bei einer weiteren Bank, bei der ich ein Konto unterhalte funktioniert es weiter einwandfrei. es gibt ekinerlei Fehlermeldung dazu.

Wer weiß denn dazu was oder hat noch dasselbe Problem?

Gruß HeyJoe

User avatar
AceBIT
Site Admin
Posts: 3450
Joined: March 20th, 2003, 8:08 pm

Re: PWD Overlay verhindert login / Sicherheitsabfrage bzgl.

Post by AceBIT » November 21st, 2012, 11:53 am

godmd wrote:
Eine weitere Beobachtung, die ich gemacht habe: Manchmal passiert es mir, dass ich F6 drücke - auf einer falschen Seite, d.h. wenn in der PWD-Topleiste z.B. versehentlich noch die Zugangsdaten meiner Bank aktiv sind, obwohl ich mich in ein Forum einloggen will. In diesem Fall werden die Loginfelder des Forums mit meinen Bank-Logindaten gefüllt. Eine recht unsichere Sache, denn die Daten werden ja nicht nur im Browser gespeichert (je nach Einstellungen), sondern i.d.R. auch in den Logdaten der jeweiligen Website. Hilfreich könnte es hier sein, wenn PWD vor dem Eintragen der Kennwörter die URL abfragen würde, ob die zum Kennwort gespeicherte URL mit der im Browser aufgerufenen übereinstimmt und einen Warnhinweis ausgibt, wenn dies nicht der Fall ist.
Sorry, wir haben ganz vergessen auf diese Vorschlag einzugehen. Die Idee ist auf jeden Fall sehr gut, hier eine optional abstellbare Warnung anzuzeigen und wir haben das schon mal in die Todo-Liste für die nächste Version aufgenommen. Vielen Dank!
Beste Grüße aus Darmstadt! - Best regards from Darmstadt!

AceBIT GmbH, Holzhofallee 15, 64295 Darmstadt, Deutschland - Tel.: +49 61 51 136 50-0, Fax: +49 61 51 136 50-20, E-Mail: info@acebit.de, Web: https://www.acebit.de

godmd
Guru
Guru
Posts: 286
Joined: February 7th, 2005, 3:30 pm

Re: PWD Overlay verhindert login / Sicherheitsabfrage bzgl.

Post by godmd » November 21st, 2012, 1:15 pm

Das freut mich, vielen Dank.

Schade, dass es zu dem anderen Problem keine Lösung gibt. Den Link meinet Bank habe ich ja oben genannt, vielleicht hilft es Ihnen ja, sich den Aufbau der Seite mal anzusehen und Ajax- sowie JS-Elemente und CSS hhinsichtlich des Einsatzes des PWD zu analysieren?

User avatar
AceBIT
Site Admin
Posts: 3450
Joined: March 20th, 2003, 8:08 pm

Re: PWD Overlay verhindert login / Sicherheitsabfrage bzgl.

Post by AceBIT » November 21st, 2012, 2:49 pm

@HeyJoe: Könnten Sie bitte die URL Ihrer Bank posten?

@godmd: In der genannten Site wird tatsächlich ein Script verwendet, welches den Anmeldebutton deaktiviert
<script language="JavaScript">
//<!--

function disableSub() {
button = document.getElementById("anmeld");
button.disabled = true;
}
//-->
</script>
Beste Grüße aus Darmstadt! - Best regards from Darmstadt!

AceBIT GmbH, Holzhofallee 15, 64295 Darmstadt, Deutschland - Tel.: +49 61 51 136 50-0, Fax: +49 61 51 136 50-20, E-Mail: info@acebit.de, Web: https://www.acebit.de

godmd
Guru
Guru
Posts: 286
Joined: February 7th, 2005, 3:30 pm

Re: PWD Overlay verhindert login / Sicherheitsabfrage bzgl.

Post by godmd » November 21st, 2012, 4:39 pm

Witzig ... Und welches Event, das die Dateneingabe durch PWD nicht (an)erkennt, aktiviert den Button wieder?

HeyJoe
Expert
Expert
Posts: 30
Joined: November 20th, 2012, 4:19 pm

Re: PWD Overlay verhindert login / Sicherheitsabfrage bzgl.

Post by HeyJoe » November 21st, 2012, 4:45 pm

hier für Acebit der URL meiner Bank:
https://www.ksk-verden.de/privatkunden/ ... F@@014@@IF
hoffentlich hilft es endlich weiter

HeyJoe
Expert
Expert
Posts: 30
Joined: November 20th, 2012, 4:19 pm

Re: PWD Overlay verhindert login / Sicherheitsabfrage bzgl.

Post by HeyJoe » November 27th, 2012, 7:02 pm

Ich habe jetzt eine Häkchen gesetzt bei "Kennwort über Browser-Add-on nicht automatisch ausfüllen lassen" und nutze die Anmeldung über den "Blitz", dann geht es.
Ist wie gesagt seit der Version 6.2.0 so, vorher ging es auch mit dem Browse-Addon. Schon komisch, weil bei letzterem die richtigen Einträge gesetzt werden aber beim Klick auf "Anmelden" wieder gelöscht werden.

Post Reply