Fehler beim Übertragen der Login-Daten mit der Maus

Forum für den Passwort-Manager "Password Depot".
Post Reply
at-biker
Expert
Expert
Posts: 51
Joined: December 10th, 2011, 1:46 am
Location: Südhessen/Odenwald

Fehler beim Übertragen der Login-Daten mit der Maus

Post by at-biker » April 11th, 2014, 10:42 am

Hallo zusammen,

schon immer fülle ich die Felder für Benutzer und Passwort so aus, dass ich mit der Maus die Daten von der Topleiste in die Login-Felder der Internetseiten ziehe.

Seit kurzer Zeit kommen bei vielen Internetseiten die falschen Daten an. Ziehe ich stattdessen die Maus in den Editor, kommen die Daten dort korrekt an.

Den Tipp, die Ausfüllmethode zu ändern, kenne ich aus einem Thread hier. Das mache ich auch, möchte aber doch gerne wieder die schnelle Maus-Methode benutzen können.

Ich bitte das AceBit - Team um eine Stellungnahme. Das das Thema nicht nur bei mir auftritt, vermute ich einen Bug in einer der letzten Revisionen der Password Depot Software. Leider kann ich nicht zurück, da ich die alten Installationsfiles nicht mehr besitze.
Ist denn Hilfe in Aussicht oder wo kann ich ältere Softwareversionen, z. B. von 2013, downloaden? Letzteres ist natürlich nur die schlechteste Lösung.

Viele Grüße
at-biker

User avatar
Stefan (AceBIT Team)
Guru
Guru
Posts: 423
Joined: June 4th, 2013, 5:19 pm

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by Stefan (AceBIT Team) » April 22nd, 2014, 11:34 am

Hallo at-biker,

das Ausfüllen per Drag&Drop funktioniert auch nach dem Ändern der Ausfüllmethode (Eintrag ändern > Erweitert).

Oder meinen Sie etwas anderes mit der "schnellen Maus-Methode"?

at-biker
Expert
Expert
Posts: 51
Joined: December 10th, 2011, 1:46 am
Location: Südhessen/Odenwald

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by at-biker » April 22nd, 2014, 12:19 pm

Guten Tag Stefan vom AceBit - Team,

Probleme habe ich tatsächlich mit der Methode Drag&Drop. Schon länger gab es einige wenige Internetseiten, wo die Drag&Drop Methode nicht funktionierte. Es wurde einfach kein Eintrag angenommen, außer Handeingabe via Tastatur. Das waren aber nur ganz wenige Fälle.

Das aktuelle Problem, dass beim "Drop" veränderte Daten eingetragen werden, ist bei mir erst seit 2014 irgendwann aufgetreten, mittlerweile bei fast allen Internetseiten, vor allem bei all meinen Bankseiten.

Ziehe ich stattdessen den Eintrag in den Editor, wird er korrekt eingetragen.

Mittlerweile nutze ich Strg + C bzw. V zum Ausfüllen. Trotzdem wäre es schön, zu wissen, warum das so passiert. Ich beobachte den Effekt auch auf den anderen Notebooks in unserem Haus, die völlig unterschiedlich konfiguriert sind.

Da ich annehme, dass nicht plötzlich alle Internetseiten verändert worden sind, bleiben nur die Möglichkeiten, dass seitens Windows Update eine Änderung bewirkt wurde oder dass nach einem Password Depot Update diese Veränderung bewirkt wurde oder dass es etwas mit der Sicherheitssoftware zu tun hat (Avira Internet Security 2014). Wenn ich noch eine ältere Password Depot Installationsdatei hätte, z. B. von 2013, hätte ich schon mal einen Test gemacht. Aber ich bin immer schnell beim Löschen, wenn ich neuere Versionen bekomme.

Bin ich der einzige User, der dieses Verhalten reklamiert?

Viele Grüße
Reinhold

User avatar
Vital
Veteran
Veteran
Posts: 81
Joined: February 11th, 2008, 11:56 am

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by Vital » April 23rd, 2014, 2:36 pm

Drag&Drop-Fehler aus der Top-Leiste heraus:
Siehe unter
http://www.acebit.com/forum/viewtopic.php?f=6&t=7341
Dort habe ich ein Hardwarefehler an meiner Maus in Verdacht gehabt. Doch der Drag&Drop-Fehler blieb auch mit der neuen Maus erhalten.
Im Firefox verursacht das Add-on 'Unhide Passwords 1.2.7.0' diesen Fehler. Wohl gemerkt nicht immer der gleiche. Manchmal fehlt das erste Zeichen des Passwortes, andermals wird das erste Zeichen ans Ende verschoben. Damit scheitert jedes Login, das in einer HTML-Seite eingebettet ist, weil da das Add-on eingreift.
Seiten, die das Passwortfeld per javascript generieren sind nicht betroffen, da dort das Add-on nicht wirkt.
Seit ich das inkriminierte Add-on abgeschaltet habe, tritt der Fehler nicht mehr auf. Das war vor 8 Tagen.

Mit freundlichen Grüßen.

at-biker
Expert
Expert
Posts: 51
Joined: December 10th, 2011, 1:46 am
Location: Südhessen/Odenwald

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by at-biker » April 23rd, 2014, 6:41 pm

Hallo Vital,

die von Dir beschriebenen Probleme kenne ich so glücklicherweise nicht, aber eben so ähnlich. Die von mir beschriebenen Probleme treten im IE und im FF auf. Die AddOns von AceBit habe ich nicht installiert, auch nicht die Windows Explorer Integration.

Mit der Strg+C bzw. Strg+V - Methode funktioniert es nun bei mir.

Eine Antwort, ob das beanstandete Verhalten mit Password Depot zu tun hat, werden wir hier wohl eher nicht bekommen.

Kann man denn noch irgendwo eine Password Depot Installationsdatei von Ende 2013 herunterladen?

Und: Gibt es Gründe, warum es wichtig ist, die jeweils neuste Version zu installieren, z. B. Sicherheit?

Viele Grüße
at-biker

icke1954
Super User
Super User
Posts: 484
Joined: May 4th, 2011, 9:25 am

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by icke1954 » April 23rd, 2014, 9:28 pm

at-biker wrote:Kann man denn noch irgendwo eine Password Depot Installationsdatei von Ende 2013 herunterladen?
PWD vom 13.12.13

Wäre nett, wenn Du ein Feedback lieferst!
Ich kann mir eigentlich nicht vorstellen, dass es an der PWD-Version liegt?!
at-biker wrote:Gibt es Gründe, warum es wichtig ist, die jeweils neuste Version zu installieren, z. B. Sicherheit?
Das solltest Du selbst entscheiden >> Versionsübersicht

Ich habe eine Freundin, die so wie Ihr, keine AddOn's der Browser nutzt und noch mit PWD-5 total zufrieden ist 8)

Gruß icke
Windows-7 64Bit ● Chrome 64Bit ● Firefox ● PWD 11.0.0

at-biker
Expert
Expert
Posts: 51
Joined: December 10th, 2011, 1:46 am
Location: Südhessen/Odenwald

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by at-biker » April 24th, 2014, 7:50 pm

Hi icke1954,

danke für die Stellungnahme und den Link. Habe die Datei geholt und werde sie bei Gelegenheit, vielleicht am Wochenende, auf meinem Notebook installieren und testen. Rückmeldung wird zugesichert.

Mit den Software-Versionen ist es halt oft so, dass auch Dinge korrigiert werden, die nicht unbedingt in der Versionsübersicht stehen, z. B. Sicherheitslücken. Daher hole ich mir schon immer sofort die aktuelle Version. Wenn dann halt neue Bugs drin sind, hat man Pech.

Viele Grüße
at-biker

User avatar
Stefan (AceBIT Team)
Guru
Guru
Posts: 423
Joined: June 4th, 2013, 5:19 pm

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by Stefan (AceBIT Team) » April 25th, 2014, 9:19 am

Hallo,

wichtige Änderungen (z.B. sicherheitstechnische Updates) werden von uns immer auch der Versionsübersicht hinzugefügt.

Nur kleine Änderungen, die z.B. die Benutzeroberfläche betreffen, werden nicht immer alle einzeln aufgezählt.

Das Problems beim Drag&Drop konnten wir bislang auch noch nicht reproduzieren. Wir warten gespannt auf Ihr Feedback, at-biker :)

at-biker
Expert
Expert
Posts: 51
Joined: December 10th, 2011, 1:46 am
Location: Südhessen/Odenwald

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by at-biker » May 1st, 2014, 7:38 pm

Hallo zusammen,

hier und heute gebe ich abschließend die zugesagte Stellungnahme bezüglich der Problemlösung (eigentlich der vermutlichen Ursache für die Fehlfunktion).

Zunächst:
Alles funktioniert wieder wie gewohnt, auf allen unserer Windows 7 Notebooks. Ich kann also wieder mit der Maus die Daten in die Login Felder ziehen.

Grund:
Leider nicht eindeutig ermittelt.

Vermutlicher Grund:
Den Versuch, mit der Password Depot Installationsdatei aus Dezember 2013 habe ich aus Zeitgründen noch nicht gemacht. Da nun alles wieder funktioniert, ist er auch nicht mehr sinnvoll.

Aber:
Auf Anraten des Support-Teams von Avira zu der seit dem Frühjahr auf allen unseren Notebooks installierten Sicherheits-Software Avira Internet Security Suite, die mit der Suite installierte ASK-Toolbar wegen mittlerweile erkannter Inkompatibilität mit den Windows 7 / 64 Bit Betriebssystemen zu deinstallieren, habe ich das auf allen Notebooks am gleichen Tag getan. Anlass waren ständige Absturzmeldungen für diese Toolbar. Normalerweise installiere ich keine Toolbars, die bei Software mitkommen. Bei der Avira Software war es so, dass ein Mehrwert, nämlich verbesserter Tracking Schutz und, soweit ich mich erinnere, noch mehr, versprochen wurde. Daher sah ich die Toolbar als Teil der Funktionalität zur Sicherheit an und erlaubte die Installation.
Seitens Avira sagte man mir nun, dass die Toolbar quasi überflüssig sei und dass demnächst eine Eigenentwicklung mit den entsprechenden "Sicherheitsfunktionen" der ASK-Toolbar zur Auslieferung käme.

Irgendwann nach der Deinstallation dieser Toolbar stellte ich zufällig fest, dass die Maus-Übertragung beim Password Depot wieder funktioniert, auch bei einigen der am stärksten betroffenen Internetseiten.

Eigentlich kann nur die ASK-Leiste bzw. deren Inkompatibilität der Grund der Fehlfunktion gewesen sein, denn es gab keine Updates von Microsoft und AceBit und es wurde auch ansonsten keine Änderungen an allen Notebooks gleichermaßen durchgeführt.

Ich bin wieder zufrieden und ich hoffe, dass meine Hinweise anderen betroffenen Usern eine Hilfe sein können.

Viele Grüße
at-biker

icke1954
Super User
Super User
Posts: 484
Joined: May 4th, 2011, 9:25 am

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by icke1954 » May 1st, 2014, 8:48 pm

Erstmal danke für Dein Feedback,
at-biker wrote:Irgendwann nach der Deinstallation dieser Toolbar stellte ich zufällig fest, dass die Maus-Übertragung beim Password Depot wieder funktioniert, auch bei einigen der am stärksten betroffenen Internetseiten.
Genauso etwas hatte ich auch im Verdacht, aber es gibt ja heute so viele unterschiedliche, Virenscanner, Firewalls, Tools, dass man den Betroffenen nicht gleich sagen will, er soll alles abschalten! D.h. hatte ich vorsichtig formuliert >>
icke1954 wrote:Ich kann mir eigentlich nicht vorstellen, dass es an der PWD-Version liegt?!
Jedenfalls wünsche ich Dir, dass es auch so bleibt... :yes:
Gruß icke
Windows-7 64Bit ● Chrome 64Bit ● Firefox ● PWD 11.0.0

User avatar
Vital
Veteran
Veteran
Posts: 81
Joined: February 11th, 2008, 11:56 am

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by Vital » May 2nd, 2014, 1:16 pm

at-biker wrote:Und: Gibt es Gründe, warum es wichtig ist, die jeweils neuste Version zu installieren, z. B. Sicherheit?
Hallo at-biker,
ich kann mir nicht vorstellen, dass sich an der Sicherheit etwas ändert, von Version zu Version. Diese liegt ja schließlich in der Verschlüsselung der Passwortdatei (in der Folge nur noch PW-Datei).
Ich bin kein Verschlüsselungspezialist, aber ich weiss, dass das Masterpasswort in die Verschlüsselung eingebunden wird. Somit würde eine Änderung an der Verschlüsselung-Methode, die PW-Datei unbrauchbar machen. So viel ich mich erinnere, wird AES verwendet. Diese Verschlüsselung ist innerhalb der PasswordDepot-Anwendung (PWD) deshalb unknackbar, weil nach jedem falschen Login ein Timer abläuft. Dieser verzögert den nächsten Versuch. Das wird gerne gemacht um automatisierte Login-Versuche zu bremsen und somit sinnlos zu machen.

Was allerdings ein Angreifer ausserhalb von PWD machen kann wenn er die verschlüsselte PW-Datei besitzt weiss ich nicht. Da könnte eine Automatisierung mit abertausenden Versuche in der Sekunden funktionieren. Aus dieser Perspektive, ist es gut, die PW-Datei nicht aus der Hand zu geben.

Bei der portablen Version könnte AceBit die Sicherheit erheblich steigern, wenn die PW-Datei nur ins RAM geladen/gehalten würde. Das Programm sollte dann das Entfernen des Stick/SD-Card erlauben. Damit könnte ein Angreifer nicht oder nur wenige Sekunden Zeit an die Passwort-Datei kommen. Bei Änderungen sollte dann das Programm den User auffordern, das Speichermedium wieder einzustecken bis die Änderung gespeichert ist.
Bei mir würde das allerdings nichts nützen, da ich noch andere Portable Anwendungen auf der SD-Card habe. Die vertragen das Entfernen der SD-Card nicht. Ich hätte aber an meinem Notebook die Möglichkeit eine 2. SD-Card für das PWD einzustecken. Hätte... Wäre... Mensch eben! Wie heißt es immer: Der Fehler sitzt vor der Tastatur.

Zum Versions-Upgrade: Das macht Sinn wenn man von sonstigen Programmverbesserung profitieren möchte. Die gibt es auch hin und wieder.
Ich selbst mache jedes Upgrade mit, auf die Gefahr hin, dass es Verschlimmbesserungen enthält. Ein Upgrade macht das Leben spannender :-)

Mit freundlichen Grüßen.

icke1954
Super User
Super User
Posts: 484
Joined: May 4th, 2011, 9:25 am

Re: Fehler beim Übertragen der Login-Daten mit der Maus

Post by icke1954 » May 2nd, 2014, 3:36 pm

Hallo
vital wrote:Diese Verschlüsselung ist innerhalb der PasswordDepot-Anwendung (PWD) deshalb unknackbar, weil nach jedem falschen Login ein Timer abläuft.
Wovon sprichts Du?
Sollte Deine PWD-Datei in fremde Hände geraten, ist es richtig, dass zu 99% der User, nicht in der Lage sein sollten, diese zu öffnen. Das sind sie allerdings auch schon ohne diese Verzögerungstechnik nicht. Für den Rest, die für das Öffnen Deiner Passworddatei sowieso nicht das org. PWD nehmen, ist es eben so wichtig, dass das Passwort die entsprechende Sicherheitskriterien (Länge, Zeichenwahl) aufweisen sollte.
vital wrote:Bei der portablen Version könnte AceBit die Sicherheit erheblich steigern, wenn die PW-Datei nur ins RAM geladen/gehalten würde.
Sollte sich ein entsprechender Trojaner auf Deinem System tummeln, ist es dem total Banane, wo Deine PW-Datei gespeichert wird. Den einzigen Vorteil, den der RAM bringen würde, wäre die Zugriffsgeschwindigkeit :?
Um die Identifizierung des Passwortes in diesem Fall zu erschweren, hat Acebit ja die Option "Cursor-Simulation" in das Programm integriert. Leider bewirkt dieses Feature nur, das dem legitimen Anwender es schwerer fällt, sein Passwort einzugeben. Durch einen Bug im Programm kann der Hacker in seiner Aufzeichung eindeutig den originalen Cursor identifizieren, da dieser sich nach dem Start immer außerhalb der virtuellen Tastatur befindet und der Eintrittsweg so eindeutig erkennbar ist :evil:
Das hatte ich schon vor mehreren Monaten bemängelt, allerdings scheint das niemanden zu interessieren. Der Umfrage nach, ist es den meisten Usern wichtiger, dass die Android / IOS - Versionen verbessert werden :oops:

Gruß icke
Windows-7 64Bit ● Chrome 64Bit ● Firefox ● PWD 11.0.0

Post Reply